User Guide
LFE - Language File Editor
for eSearch .lang files
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Welcome!

Our aim with eSearch is to make it available in YOUR language!
We designed it so that YOU can translate it easily however you
wish, for example you may prefer different words on a menu or

want to change a shortcut key.

Using the Language File Editor is quicker and less error prone
than doing it manually, especially when updating to a new
eSearch version.

Location of .lang files

In the Desktop version they are in the AppData folder:
e.g. C:\Users\Username\AppData\Roaming\eSearch\il8n\

In the Portable version they are under the install folder e.g.
Program Files\ElectronArt Design Ltd\eSearch\il8n\

eSearch License

The eSearch license allows you to translate the user interface
for your own personal or organisations use, you may not sell or
license the translated files to others.

If you would like to donate translations for use by others,
please send them to support@electronart.co.uk they will be
published or distributed free of charge to use with eSearch on
as AS-IS basis, with no warranty of accuracy or completeness.



Translating an existing language file

If you have installed eSearch for the first time and need to
correct an error in the UI text or want to replace text in one
of the supplied .lang files with your preferred translation you
need to first compare it with the template.lang file:

From the File menu > Open.. navigate to the .lang file located
in the AppData folder for eSearch.

Click on Edit > Compare, it will compare it with the
template.lang in the same folder and show the differences if
any. Press OK, if there are new strings in the latest template
the ¢‘Not translated’ value will increase.

Click on the >> button to jump to the next untranslated line or
scroll through to the text you want to edit, delete the text in
the translated column, then enter the correct translation of
the English word(s) shown in the Original (left-hand) column.

File Edit Help

CUsers\[ 2 pData\ Roaming\eSearchiil8n\de-DE.lang

Title

Score
Created
Maodified
Indexed

Path

File not found
Something went wrang
oK

Cancel
Append Date
Words

Filters

Total strings: 207 Mot Translated: 0

Titel

Punltzahl

Erstellt

Gedndert

Indiziert

Pfad

Datei nicht gefunden

Etwas ist schief gelaufen

oK

Abbrechen

Datumn anhangen

Warter

Filtar

Translated: 100.00 %

IMPORTANT: When finished File > Save...
the existing file.
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and choose to overwrite




Updating a .lang file
When a new version of eSearch is installed, if the UI language

is not the default English, you need to check if the
appropriate .lang file needs updating.

Open the .lang file that you want to use, click on Edit >
Compare and it will show the differences between the
template.lang file in the same folder and the translation.
Press OK, if there are new strings in the latest template the
‘Not translated’ value will increase.

Click on the >> button to move to each line that needs
updating.

IMPORTANT: When finished File > Save... and choose to overwrite
the existing file.

Creating a new .lang file

First check that no suitable .lang file is installed, from the
File menu > Open.. navigate to the AppData folder for eSearch.
If you cannot find the language you need, you can create a new
language file from scratch.

Make a copy of the template.lang file and copy it to your
Documents folder or somewhere else that you have write
permission. Rename it using IETF language codes such as fr-CA
for Canadian French, then copy the file back into the il8n
folder. IETF Language codes can be found here:

https://datatracker.ietf.org/doc/html/rfc56u46

From File > Open.. navigate to the AppData folder and locate the
file you have just created. It should show that 0% has been
translated in the status bar.

Click on the >> button to get to the first string that needs
translating, be sure to enter the correct IETF code in the
first line, to ensure that dates and sorting are localized
correctly.


https://datatracker.ietf.org/doc/html/rfc5646

IMPORTANT: When finished File > Save... and choose to overwrite
the existing file.

.lang File Format

Translation files are read line by line.
First line = Identifier/Fallback string.

(Do not edit or remove!)

Second line = Translation.

(Remove test word in brackets & replace with translation of
line above.)

Comments start with a # and no other character must precede #

Blank lines are not permitted unless they have a # at the start
to comment them out.

10}, {1}, etc. represents a variable value and should be copied
into the translation as-is.

Shortcut keys

Words that start with an underscore are Menu items, the
underscore precedes the Alt shortcut key. E.g. _Exit means the
user must press ALT + E to exit the application.

You must ensure that shortcut keys are unique. You can choose
another character instead of the first character, for example
you could change _Exit to E_xit to make the shortcut Alt + x to
close the program.



Character Map

If you don’t have a suitable keyboard for the language you are
translating, the Windows Character Map can be opened from the

Edit Menu.

Select a character, then Copy and Paste into the translation.

&P Character Map =
Font: | (} Courier Mew vl Help
Cle|(c|e|D|d|p|d|E|e|E|&|E|&|E|e|E|&|G|G
Glg|Glglelg|a|lhlg|n|I|i|I|z|I|i|T|i|1|2
T|H|J|§|B|k|x|L|1|L|1|T|I|&|:|E|E|N|A(N
n|N|aln|D|n|0|5|0|85|0|8|E|e|R|f|R|x|R|F
S5 P S|s|T|&|T|t|F|(e|U|Q|T(Q|U|0
vg U W|w|Y|v|¥|2|z|a|z|2|z|T|b|B
E|Broreroic | c|p|D|a|alo|z|ale|F|fle|v|w
I ElE|T|A|\U|N|(g|e|0|o|qd|q|P|E|R|2|2|E
11| TIE|TIT|x|B|D|Y|(VI|E|2|3|8|z|2|2|5|B
slpll|V]|#+|! | E &L L LW EHMAIIL|O
Characters to copy: a1 Select Copy
B advanced view
Character set: Unicode ~ | Go to Unicode:
Group by: Al K
Search for: Search

U+0171: Latin Small Letter U With Double Acute




Sample .lang files

With the initial release of eSearch we have provided 100%
translated* sample .lang files in German and French.

Many other sample .lang files are available with at least 5%
translation.

*Note: the translations have not been checked by native
speakers, errors may exist.



Licence & Notices

License .htm and Notices.htm are in the ‘docs’ folder, copies
of texts are below:

License Agreement for LFE - Language File Editor application (**The Licensed
Software")

By installing this software, you (the Licensee) agree to the terms of this License Agreement, if you do not
agree then do not proceed with the installation. "Licensor" is ElectronArt Design Ltd. Registered in England
& Wales: 0796515 Registered Office: 124 City Road, London EC1V 2NX. United Kingdom.
www.electronart.co.uk, SearchCloudOne.com

1 License Scope.

1.0 The Licensed Software is an end-user application only, in the absence of a signed written agreement
with the Licensor it may not be distributed with any other product. If wider distribution is needed, please
contact sales@electronart.co.uk.

1.1 The licensed Software is distributed in object form by Licensee, source code is not included.

1.1a The licensee may use the software for the exclusive purpose of translating .lang files distributed with
certain products of the Licensor.

1.2 The software license is assigned to the computer on which the software is installed, that computer is the
licensed computer. You may transfer the software to another computer provided you uninstall the copy from
the previous licensed computer.

2 General Use Limitations.

2.1 The Licensed Software is protected by copyright laws and other international treaties, as well as other
intellectual property laws and treaties. The Licensed Software is licensed, not sold, according to the terms of
this License Agreement.

2.2 Licensor grants, and Licensee hereby accepts, an irrevocable, non-exclusive, and world-wide license to
use the Licensed Software.

2.3 Except as expressly provided herein, Licensee may not distribute, copy, reproduce, sub-license, sell or
otherwise transfer the Licensed Software. Licensee may make backup copies of the Licensed Software
strictly for Licensee's archival purposes.

2.4 Licensee may not modify, adapt, or create derivative works based on the Licensed Software.

2.5 The translated .lang files may not be sold or licensed to others. Licensor will offer free distribution of
any translated .lang files that Licensee may wish to donate for that sole purpose on an AS-1S basis, see
section 4.1

2.6 Licensee may not assign or otherwise transfer its rights under this agreement without written permission
from the Licensor, which permission shall not be unreasonably withheld, except in the case of a sale of
substantially all assets of Licensee's company or the merger or acquisition of Licensee's company into a new
company, in which case Licensee may transfer its rights under this agreement to the acquiring party.



3. Maintenance and Support

3.1 Licensor agrees to make available to Licensee any maintenance releases, new and enhanced versions or
upgrades of the Licensed Software for a period of one year.

3.2 Licensor agrees to provide technical support via email to a single point of contact designated by the
Licensee for a period of one year from the date of this license.

4 Limitations on Warranty and Liability.

4.1 The Licensed Software is provided AS IS. To the extent permitted by applicable law, ANY AND ALL
OTHER REPRESENTATIONS AND WARRANTIES, EXPRESS OR IMPLIED, INCLUDING BUT NOT
LIMITED TO IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR
PURPOSE, AND NON-INFRINGEMENT, except as stated in section 4.4, below, ARE EXPRESSLY
EXCLUDED AND DISCLAIMED. LICENSOR AND ITS SUPPLIERS DO NOT AND CANNOT
WARRANT THE PERFORMANCE OR RESULTS LICENSEE OR LICENSEE S END-USERS MAY
OBTAIN BY USING THE SOFTWARE.

4.2 IN NO EVENT SHALL LICENSOR BE LIABLE FOR INCIDENTAL OR CONSEQUENTIAL

DAMAGES, including lost profits, lost savings, lost opportunities or other incidental or consequential
damages arising out of the use of or inability to use the Licensed Software, even if Licensor has been

advised of the possibility of such damages.

4.3 UNDER NO CIRCUMSTANCE MAY LICENSOR'S LIABILITY TO LICENSEE, UNDER ANY
AND ALL PROVISIONS OF THIS AGREEMENT, EXCEED THE LICENSE FEE.

4.4 To the extent that Licensor remains legally liable to Licensee, such liability shall expire one year from
the date of this Agreement.

4.5 Subject to the limitations on liability contained in sections 4.1, 4.2, 4.3, and 4.4 Licensor represents and
warrants: that it owns the Licensed Software or has requisite authority to enter into this transaction; that the
Licensed Software, when properly used as contemplated herein, will not infringe or misappropriate any
copyright, trademark, or the trade secrets of any third persons; and that to the best of Licensor s knowledge,
the Licensed Software does not infringe any patents of third persons.

5 General Terms.

5.1 The failure to immediately enforce any provisions, rights or remedies under this contract shall not
constitute a waiver by the party failing to enforce such provision, even if the party failing to enforce such
provisions, rights or remedies is aware of the other party's contractual breach.

5.2 This agreement shall be interpreted under English Law.

5.3 Either party may terminate this agreement upon written notice if the other party materially violates any
provision of this agreement and fails to remedy such violation within twenty-eight (28) days of receipt of a
second written notice thereof, if such violation has not already been remedied following twenty-eight (28)

days from receipt of a first written notice thereof. Evidence of delivery of such written notice, by recorded

delivery for instance, is required.

5.4 This agreement contains the entire agreement between the parties, superseding all previous agreements.
This agreement may not be amended other than by a written agreement.

5.5 If any portion of this agreement is found to be invalid, the remainder shall continue in force.
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Notices and Acknowledgements for LFE - Language File Editor application ("The Licensed
Software")

LFE - Language File Editor uses some 3rd party software in binary form:

1) PseudoLocalizer.dll https://github.com/bymysl|f/PseudoL ocalizer"

Details of the MIT License is below:

=====—======== | |CENSES ==== == = ===

e 1) MIT license

For use with eSearch 1.0.8958

Issue: 5
Copyright © 2024 ElectronArt Design Ltd.


https://github.com/bymyslf/PseudoLocalizer
https://github.com/bymyslf/PseudoLocalizer?tab=MIT-1-ov-file

